
XFS 2D Barcode 1.0 User Manual 

 

 

 

 

Xtra Final Software 

XFS 2D Barcode  

User Manual 

Version 1.0 

 

 

 

 

 

 

http://www.xtrafinal.com

Copyright © 2005-2006 Xtra Final Software, Inc. All rights received. 

Xtra Final Software, Inc.         - 1 - 

http://www.xtrafinal.com/


XFS 2D Barcode 1.0 User Manual 

 This manual, as well as the software described in it, is furnished under license and maybe 
used or copied only in accordance with the terms of such license. The content of this manual is 
furnished for information use only, is subject to change without notice, and should not be 
construed as a commitment by Xtra Final Software, Inc. XFS assumes no responsibility or 
liability for any errors or inaccuracies that may appear in this documentation. Except as 
permitted by such license, no part of this publication may be reproduced, stored in a retrieval 
system, or transmitted, in any form or by any means, electronic, mechanical, recording, or 
otherwise, without the prior written permission of Xtra Final Software, Inc. 

Any references to company names in sample templates are for demonstration purposes only 
and are not intended to refer to any actual organization. 

 All other trademarks are the property of their respective owners. 
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Introduction 

XFS 2D Barcode is a powerful Barcode editor and Printer, which can generate all types of in 
common used 1D barcode, can support any paper of sales on the market, can import data 
from every database provider, completely WYSIWYG(What You See Is What You Get), 
absolutely easy to use. 

XFS 2D Barcode works as a stand-alone program, and you can export Barcode images to 
other graphics formats such as GIF, JPG, BMP etc. Using copy/paste function, you can paste 
the Barcode image to your favorite graphics application for further edit. 

Major Features  

XFS 2D Barcode includes many advanced features, such as: 

 2D Barcode: PDF417, Code16K 
 New XFS 2D Barcode Sheet is a very strong power tool. You can specify any attributes of 

barcode you needed. Including Brand , Product Name , Symbology , Barcode value, 
Count that you want to generate barcode and Continuous. The most useful function is that 
you can specify your barcode if continuous, by this way, you can get a sequence of 
barcodes conveniently.     

 Zoom In/Zoom out functions: you can view the Barcode in details and export it to other 
applications.  

 Rotate left/right functions: you can change the rotate for view and printer. 
 WYSIWYG: What You See Is What You Get. 
 Inches or centimeters unite measurement: you can measurement the Barcode’s width or 

height by inch or centimeter.  
 The entire Barcode Label can be exported to images formats such as BMP, GIF, JPG, 

and PNG. The Barcode can also be copied to the Windows clipboard to allow other 
applications to use.  

 Paper Template Support: Supports more than 200 label paper templates, and, you can 
add new barcode Label or delete barcode label if you wish.  

 Import data from database: you can import data from any provider database.  

System Requirements  

 CPU: Requires at least a Pentium (or better) PC running Microsoft Windows 98SE, 
Windows Me, Windows 2000, Windows XP, or Windows 2003 or later. Windows 2000 
and above operating systems are recommended.  

 Printer: To print a quality Barcode, you need a dot matrix/ink jet/thermal/laser printer. For 
best quality and cost savings, we recommend you to use a laser printer to print Barcode 
images.  

 Hard Drive Space: To download and install XFS 2D Barcode on your PC, you need at 
least 5 megabytes of free space.  
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Installing 

Before you can run XFS 2D Barcode you must first install it by running the Setup Program.  

1) Download the setup file. You can download it on many websites.  

2) Execute the Setup file. If you downloaded the setup file from many web site, the installation 
program is in EXE format. Run the program by double clicking the ASLGen.exe. 

 

Follow the directions displayed by the Setup program and finish the installation. 

Uninstalling 

If, for any reason, you need to remove the IBE Barcode Studio, you need to click the 
“Modify/Remove” button under the “IBE Barcode Studio” icon in the “Add/Remove Programs” 
in the control panel.  

 

You can also do this by click the Uninstall XFS 2D Barcode in the start menu. 

Follow the directions displayed by the Uninstall program and finish the removal.  

Registering 

The software initially installed as a shareware version, you need to pay $29.99 for the license. 
You can buy it click here. 

After buy it, the vendor will send the series number via Email. 

Then you can update the demo to the full version; enter the registration code under the 
“Help->Register” menu. 
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Getting Help  

Please read the user manual that comes with this software for more usage and 
troubleshooting options.  

To report problems and bugs, or to get technical support, please send an Email to 
support@xtrafinal.com.   

Running XFS 2D Barcode 

Once installed, XFS 2D Barcode program group is added to your start menu, and a shortcut of 
XFS 2D Barcode is added to your desktop. To run XFS 2D Barcode, right click or double click 
this icon. 

Once the program is launched, you will see the main program interface. 
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Creating a New Barcode 

You can create a new Barcode by pressing the “New” button on the toolbar, or selecting the 
“New” command under the “File” menu. In any case, the program shows the default Barcode 
Image. You can change the Barcode format(i.e., Symbology), text, user field1 and user field2 
at any time. 

Save a Barcode file 

You can save the details of your Barcode to a file on your floppy, flash ROM or hard disk using 
the “Save” command under the “File” menu or by pressing the “Save” button on the Toolbar. 
This brings up the Save File dialog box and you can give your Barcode file name. 

Saving a Barcode file under a different name 

You can save the details of your Barcode to a file on your floppy, flash ROM or hard disk using 
the “Save as” command under the “File” menu This brings up the Save File dialog box and you 
can give your Barcode file name. 

Opening an existing Barcode file 

Once a Barcode has been save to a file on disk, you can it using the “Open” command under 
the “File” menu or by pressing the “Open” button on the Toolbar. This command shows you the 
standard windows open dialog, and you can select the file to open. 
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XFS 2D Barcode uses the “.xbc” file extension. Double –clicking on any file with that extension 
or open any these format files by the file explorer will launch the XFS 2D Barcode and open it. 

Measuring the Barcode by ruler 

XFS 2D Barcode has both vertical and horizontal rulers. The horizontal ruler’s width depends 
on the paper’s width which you selected. For example, when you select a paper, the ‘paper 
size’ is ‘A4’, then the width of the horizontal ruler is 21 cm. Also you can view the rulers by 
Inches or centimeter unit by setting the “Measurement Unit” in the “Options” Dialog. 

Generator the Barcode’s value or user field2 from database 

XFS 2D Barcode can import the value or user field2 from database’s field. You can select the 
“*From Database” item in the “Value“ ComboBox. This will bring up a “Database wizard” 
dialog.  

 

We will take the “Northwind” database as a example. In our example we will take the “OrderId” 
field which in the “Orders” table as the Barcode’s Text, and will take the “OrderDate” as the 
User field2’ s Text. 

1.The first step is selecting database provider: 
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In our example we select the “Microsoft OLE DB Provider for SQL Server”. Also you can select 
any others database providers. 

2.The second step is selecting database table: 

Xtra Final Software, Inc.         - 8 - 



XFS 2D Barcode 1.0 User Manual 

 

In our example we select the “Orders” table. 

3.The last step is selecting field:  

 

In our example we select the “OrderID” as a field for Barcode Text, select the “OrderDate” as a 
field for User Field2. 

In the end, you should click the “Finish” button to finish the wizard, and generator the barcodes. 
Then you will see: 
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In this picture, you can see that the Barcode Text is corresponding with the database’s field 
“OrderID” and the User Field2 corresponding with the database’s field “OrderDate”. 

Setting the Paper template 

Pressing “Paper setting” command under the “Tools” menu will show you up the “Paper 
setting” dialog. 
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Printer preview 

You can preview the Barcode(s) before printer it by pressing “Preview” command in “File” 
menu. 
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Using the Toolbars 

There are tow Toolbars in the XFS 2D Barcode. 

 

First one is the standard Toolbar, witch is the mirror of the menu’s commands.  

 

Other is a simple Toolbar, which can page up, page down, page home and page end the 
document. 

Using the Rebars 

Changing Font Typeface and Size 

To changing the typeface of the font used in the Barcode, click on the down arrow of the font 
face picker. The font picker displays the font using text drawn with the font. You can also 
change the font size, and add bold, italic and underline to your text. We recommend you use 
font size 8 since it is standard size in all open systems. 

 

Note that the text attributes you select are applied to ALL text in the Barcode. 

Hiding the Text Form of the Barcode 

You can hide the text form of the Barcode by un-checking the checkbox “Barcode Value”. You 
can also enable the text form by checking the same checkbox. The text form of the Barcode is 
always shown under the actual Barcode. 

 

Changing the Barcode Text 

The combo box at the right side of the “Show Text” checkbox provides input for the encoded 
message, or so called Barcode text. 
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You can also set the Barcode to automatically increment (decrement) by one on the paper you 
print by choosing “+1” (“-1”) from the dropdown list on the right. To use this feature the last 
three character of the Barcode text must be numbers. 

Note: If the value is not a number, XFS 2D Barcode append a numeric string at end of the true 
value. 

XFS 2D Barcode can get the Barcode Text from database, it almost support the all the 
database providers. You can get the Barcode Text by finishing the wizard. See “Generator the 
Barcode’s value or user field2 from database” section. 

Changing the Quantity of Barcode Labels 

The “Quantity” combo box allows you to change the quantity of barcode labels printed, this 
option is only valid when the barcode increment is a non-zero value. 

Defining Optional User Field 1 and User Field 2 

You can define two optional fields that will be included as part of the Barcode label print, 
User Field 1: This is a text field which will be printed on top of the Barcode. This field does 

not support auto-increment. 

 

User Field 2: This is a numeric field which will be printed on the bottom of the Barcode. This 
field supports auto-increment or auto-decrement if the data entered is numeric.  

 

Rotating Barcode 

The Barcode image can be rotated in 90, 180 and 270 angles. Click the to rotate anticlockwise, 
and the to rotate clockwise. Image rotation can also be done via “Rotate Left” and “Rotate 
Right” under the “Tools” menu.  

 

Zooming In/ Out of the Barcode 

The Zoom In/Out commands/buttons scale up/down the current view of the Barcode. They do 
not change the printed or exported Barcode size. 

 

Using Barcode Studio with Other Programs 
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You can exchange data between XFS 2D Barcode and other programs using the clipboard 
and the standard edit command: “Copy”. The clipboard is a place that Windows temporarily 
stores text, pictures and other data that have been copied so that they can be transferred to 
another document or program with a “Paste” command. Copy: The “Copy” command transfers 
all the Barcode image to the clipboard. If you use the Barcode image in another application, 
make sure that you work with physical size not pixels. Export: XFS 2D Barcode allows 
Barcode image to be exported to a variety of image formats, including JPG, BMP, GIF and 
PNG. 

Exporting Images 

Choose “Export” from “File” menu, it pops up the standard file dialog. Choose the image type 
you want to export to, type the file name and press OK. The program converts the image into 
the format you specified and saves it to the disk 

Changing to the Toolbox edit mode 

XFS 2D Barcode also can edit the Barcode by using the Toolbox mode, you can change to 
that mode by pressing the “Show Toolbox” in the view menu. Then you will see the form like 
this: 

 

 

Setting Options 
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Select “Tools->Options”, then the “Options Dialog” show up. 

 

 Measurement Unit: setting the “Measurement Unit”, it can change the ruler’s 
Measurement unit.  

 Font: setting the initial barcode’s value, field1 and field2’s font.  
 ToolBar: setting the view mode of program. 
 PDF417 Setting: setting the options for PDF417 only. 
 Print Adjustment: Some Printer has excursion, then the result of printing will not 

the same with what your see. Then you should setting this “Adjustment”. Negative 
for left/up and plus for right/down. 

Supported Symbologies 

XFS 2D Barcode currently supports tow major Barcode formats PDF417 and Code16K 

Different symbologies have different character set and printing requirements. The program 
expects you input the data correctly You do not worry about check digits since this part is 
handled by the program automatically. 

PDF417 

DF417 is a multi-row, variable-length symbology with high data capacity and error-correction 
capability. PDF417 has some unique features which makes it the widely used 2D symbology. A 
PDF417 symbol can be read by linear scanners, laser scanners or two-dimensional scanners. 
PDF417 is capable of encoding more than 1100 bytes, 1800 text characters or 2710 digits. Large 
data files can be encoded into a series of linked PDF417 symbols using a standard methodology 
referred to as Macro PDF417. 
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Character Set - All 128 ASCII characters, All 128 extended ASCII characters, 8-bit binary data; 

Symbol Size - 3 to 90 rows, 90 to 583X in width 

Bidirectional Decoding - Yes 

Error Correction Level - 0 (no error correction) to 8 (the maximum error correction level) 

Additional Options - Macro PDF417, Truncated PDF417, Global Label Identifier(GLI) 

Code16K 

Code 16k is interesting because it's essentially a lot of reverse-video code128 rows stacked on top 
of one another, with some bearer bars, start/stop characters, a start symbol, padding, and check 
symbols thrown in. 

A Code 16k block may contain up to 16 rows, separated by horizontal bearer bars. The top and 
bottom of the symbol have longer bearer bars to include a leading and trailing quiet zone. Each 
row has its own start and stop character and contains 5 symbols. PAD characters must be inserted 
to make a row contain 5 symbols if necessary.
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Limited Use License Agreement 

XFS 2D Barcode Software 

_____________________________________________________________________ 

This is a legal agreement between you as the end user, and Xtra Final Software(XFS).  By 
installing the enclosed software you are agreeing to be bound by the terms of this 
agreement.  If you do not agree to the terms of this agreement, promptly exit the install 
program and return all accompanying items (including written documentation) to the place you 
obtained them, for a full refund. 

GRANT OF LICENSE.  XFS grants you the right to use one copy of the enclosed software 
program (the SOFTWARE) on a single terminal connected to a single computer, with a single 
CPU, or mobile computer (laptop, notebook, portable, handheld PC, etc.).  You may not 
network the SOFTWARE or otherwise use it on more than one computer or mobile computer 
at the same time.  

COPYRIGHT.  The SOFTWARE is the proprietary property of or under license to Xtra Final 
Software, Inc. and is protected by United States copyright laws and international treaty 
provisions.  Therefore, you must treat the software like any other copyrighted material except 
that you may (a) make one copy of the SOFTWARE solely for backup or archival purposes, or 
(b) transfer the SOFTWARE to a single hard disk provided you keep the original solely for 
backup or archival purposes, or c) transfer the SOFTWARE to a single system, which includes 
a host computer with a hard disk, provided you keep the original solely for backup or archival 
purposes.  The backup copy must include all copyright information contained in the 
original.  You may not copy the written materials accompanying the SOFTWARE.  

OTHER RESTRICTIONS.  You may not rent or lease the SOFTWARE, but you may transfer 
the SOFTWARE and accompanying written materials on a permanent basis provided you 
retain no copies and the recipient agrees to the terms of this agreement.  You may not reverse 
engineer, decompile or disassemble the SOFTWARE.  If SOFTWARE is an update, any 
transfer must include the update and all prior versions.  Your rights under this License will 
terminate automatically without notice from XFS if you fail to comply with any term(s) of the 
License.  

Limited Warranty .  

NO OTHER WARRANTIES.  XFS disclaims all other warranties, either express or implied, 
including but not limited to implied warranties of merchantability and fitness for a particular 
purpose, with respect to the SOFTWARE and the accompanying written materials.  This 
limited warranty gives you specific legal rights. You may have other which vary from state to 
state.  

Xtra Final Software, Inc.         - 17 - 



XFS 2D Barcode 1.0 User Manual 

NO LIABILITY FOR CONSEQUENTIAL DAMAGES.  In no event shall XFS or its suppliers be 
liable for any damages whatsoever (including, without limitation, damages for loss of business 
profits, business interruption, loss of business information, or other pecuniary loss) arising out 
of the use of or inability to use the SOFTWARE, even if XFS has been advised of the 
possibility of such damages.  Because some states do not allow the exclusion or limitation of 
liability, for consequential or incidental damages, the above limitation may not apply to you.  

EXPORT LAW ASSURANCES.  You may not use or otherwise export or reexport the 
SOFTWARE except as authorized by United States law and laws of the jurisdiction in which 
the SOFTWARE was obtained.  In particular, but without limitation, none of the SOFTWARE 
may be used or otherwise exported or reexported (a) into (or to a national or resident of) a 
United States embargoed country or (b) to anyone on the U.S. Treasury Department's list of 
Specially Designated Nationals or the U.S. Department of Commerce's Table of Denial 
Orders.  By using the SOFTWARE, you represent and warrant that you are not located in, 
under control of, or a national or resident of any such country or on any such list.  

CONTROLLING LAW AND SEVERABILITY.  This License shall be governed by the laws of 
the United States and the State of California.  If for any reason a court of competent 
jurisdiction finds any provision, or portion thereof, to be unenforceable, the remainder of this 
License shall continue in full force and effect. 
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